CentOS 6のrubyにmsgpack-rpcが入らない

# gem install msgpack-rpcを叩くと、ruby/io.hが無いと怒られる。

CentOSrpm/yumで入るrubyが1.8.7でかなり古いため。

さてどうしたものか考えて、バージョンを上げることに。

dotnsf.blog.jp

ここにあるとおり進めて、さほど詰まらず出来ました。

2.2.3を入れるにはreadline-develyumで入れておいた方が良いみたい。