読者です 読者をやめる 読者になる 読者になる

cocoapodsがインストールできない

  • 家のMacにgem install cocoapods すると、SIZEOF_LONGがどうこうと言われる。rubyがEl Capitanので、2.0とやや古いのが行けなさそうな雰囲気。
  • rbenvでruby 2.3を入れようとするとssl周りで怒られて駄目なので、まずport install opensslでopensslを入れる。2.3のインストールに成功。
  • で、gem install cocoapods でpodがインストールできたが、事情があってcocoapods 0.39.0を使っていた(1.0系のためのPodfileの変更がまだできてない)ので、pod installするとto_aryが無いと怒られる。
  • どうもruby 2.3に対応してるのはcocoapods 1.0以降であるらしい。ということで、ruby2.2 を入れて、gem install cocoapods もやり直して(やり直さないとruby 2.3を使うpodコマンドが残る。)ようやくpod installに成功。